SafeNet Authentication Service
MobilePASS for BlackBerry Deployment Guide
Document Information

<table>
<thead>
<tr>
<th>Product Version</th>
<th>MobilePASS 8.2, 8.3 for BlackBerry 7.1 and previous versions, with BES 5.0 MobilePASS 8.4 for BlackBerry OS 10.2 or later, with BES 10/12</th>
</tr>
</thead>
<tbody>
<tr>
<td>Document Part Number</td>
<td>007-012521-001, Rev C</td>
</tr>
<tr>
<td>Release Date</td>
<td>April 2015</td>
</tr>
</tbody>
</table>

Trademarks

All intellectual property is protected by copyright. All trademarks and product names used or referred to are the copyright of their respective owners. No part of this document may be reproduced, stored in a retrieval system or transmitted in any form or by any means, electronic, mechanical, chemical, photocopy, recording, or otherwise, without the prior written permission of SafeNet, Inc.

Disclaimer

SafeNet makes no representations or warranties with respect to the contents of this document and specifically disclaims any implied warranties of merchantability or fitness for any particular purpose. Furthermore, SafeNet reserves the right to revise this publication and to make changes from time to time in the content hereof without the obligation upon SafeNet to notify any person or organization of any such revisions or changes.

We have attempted to make these documents complete, accurate, and useful, but we cannot guarantee them to be perfect. When we discover errors or omissions, or they are brought to our attention, we endeavor to correct them in succeeding releases of the product.

SafeNet invites constructive comments on the contents of this document. These comments, together with your personal and/or company details, should be sent to the address or email below.

<table>
<thead>
<tr>
<th>Contact Method</th>
<th>Contact Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mail</td>
<td>SafeNet, Inc.</td>
</tr>
<tr>
<td></td>
<td>4690 Millennium Drive</td>
</tr>
<tr>
<td></td>
<td>Belcamp, Maryland 21017, USA</td>
</tr>
<tr>
<td>Email</td>
<td><a href="mailto:TechPubs@safenet-inc.com">TechPubs@safenet-inc.com</a></td>
</tr>
</tbody>
</table>
Contents

Preface .......................................................................................................................... 4
Support Contacts ............................................................................................................ 4

CHAPTER 1 Deploying MobilePASS for BlackBerry OS 10.2 or Later ......................... 8
Applicability .................................................................................................................... 8
Deployment Options ...................................................................................................... 8
Deployment of MobilePASS for BlackBerry OS 10 ...................................................... 8
 Creating a Shared Application Folder ......................................................................... 8
 Adding the Location of the Shared Folder to BES ...................................................... 9
 Adding the MobilePASS Application to BES ............................................................. 9

CHAPTER 2 Deploying MobilePASS for BlackBerry OS 7.1 and Earlier ..................... 11
Applicability .................................................................................................................. 11
Deployment Options ..................................................................................................... 11
Deployment via BlackBerry Enterprise Server (BES) ................................................ 11
 Pushing MobilePASS for BlackBerry in BES ........................................................... 11
 Creating a Shared Application Folder ...................................................................... 12
 Adding the Location of the Shared Folder Containing MobilePASS to BES ............ 12
 Adding the MobilePASS Application and Daemon to be Pushed to BlackBerry Devices .......................... 13
 Creating and Managing an Application Control Policy .......................................... 15
 Setting Parameters for MobilePASS BES Deployment ........................................... 16
 Installing MobilePASS on the BlackBerry Device from the SafeNet-hosted OTA Server .......................... 18
 Installing MobilePASS on the BlackBerry Device from a Web Server ...................... 18
 Hosting MobilePASS for BlackBerry on a Web Server for Over-the-Air Deployment .... 19
 Customizing MobilePASS for BlackBerry ................................................................. 19
 Customizing MobilePASS to Enroll to a Custom SAS Installation .......................... 20
 Parameters for MobilePASS for BlackBerry Deployment ......................................... 21
Support Contacts

If you encounter a problem while installing, registering, or operating this product, please make sure that you have read the documentation. If you cannot resolve the issue, contact your supplier or SafeNet Customer Support. SafeNet Customer Support operates 24 hours a day, 7 days a week. Your level of access to this service is governed by the support plan arrangements made between SafeNet and your organization. Please consult this support plan for further information about your entitlements, including the hours when telephone support is available to you.

Table 1: Support Contacts

<table>
<thead>
<tr>
<th>Contact Method</th>
<th>Contact Information</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Address</strong></td>
<td>SafeNet, Inc.</td>
</tr>
<tr>
<td></td>
<td>4690 Millennium Drive</td>
</tr>
<tr>
<td></td>
<td>Belcamp, Maryland 21017, USA</td>
</tr>
<tr>
<td><strong>Phone</strong></td>
<td></td>
</tr>
<tr>
<td>US</td>
<td>1-800-545-6608</td>
</tr>
<tr>
<td>International</td>
<td>1-410-931-7520</td>
</tr>
<tr>
<td><strong>Technical Support</strong></td>
<td><a href="https://serviceportal.safenet-inc.com">https://serviceportal.safenet-inc.com</a></td>
</tr>
<tr>
<td><strong>Customer Portal</strong></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Existing customers with a Technical Support Customer Portal account can log in to manage incidents, get the latest software upgrades, and access the SafeNet Knowledge Base.</td>
</tr>
</tbody>
</table>
CHAPTER 1

Deploying MobilePASS for BlackBerry OS 10.2 or Later

Applicability

The information in this chapter applies to:

- BlackBerry OS 10.2 or later
- BlackBerry Enterprise Server 10 or 12
- SafeNet MobilePASS 8.4 for BlackBerry and higher

Deployment Options

MobilePASS 8.4 for BlackBerry OS 10 is deployed on BlackBerry OS 10.2 or later devices via BlackBerry Enterprise Server (BES). Other deployment methods are not supported.

MobilePASS 8.4 for BlackBerry OS 10 is provided as a .bar file.

Deployment of MobilePASS for BlackBerry OS 10

**To deploy MobilePASS for BlackBerry via BES:**

1. Create a shared application folder and place the MobilePASS for BlackBerry application file (.bar) in the folder.
2. Add the location of the shared folder to BES (see page 9).
3. Add the MobilePASS application (.bar file) to be pushed to BlackBerry devices (see page 9).

Creating a Shared Application Folder

Create a shared folder for the MobilePASS application on the local disk of the BES or on a network volume that the BES can access.
CHAPTER 1: Deploying MobilePASS for BlackBerry OS 10.2 or Later

Adding the Location of the Shared Folder to BES

To add the location of the shared folder containing MobilePASS to BES:

1. Log in to the BES Admin Console at: https://<server_name>:3443/webconsole/login/
2. Under Servers and components, click BlackBerry Solution Topology > BlackBerry Domain > Component View > BlackBerry Administration Service.
3. Scroll to the bottom of the page, click Edit, and then enter the location of the shared folder in the Software management section.

Adding the MobilePASS Application to BES

To add MobilePASS for BlackBerry OS 10 to BES:

1. Under BlackBerry solution management, click Software > Applications > Add or update applications.
2. Click **Browse** and navigate to the `.bar` file.

3. Click **Next**.

SafeNet MobilePASS is displayed in the list of published applications.
CHAPTER 2 Deploying MobilePASS for BlackBerry OS 7.1 and Earlier

Applicability

The information in this chapter applies to:

- SafeNet MobilePASS for BlackBerry 8.2/8.3
- BlackBerry Enterprise Server 5.0
- BlackBerry OS 7.1 and earlier

Deployment Options

MobilePASS for BlackBerry can be deployed to devices running BlackBerry OS versions 5.0 to 7.1 using one of the following methods:

- Deployment via BlackBerry Enterprise Server (BES) (see page 11)
- Installing MobilePASS on the BlackBerry Device from the SafeNet-hosted OTA Server (see page 18)
- Installing MobilePASS on the BlackBerry Device from a Web Server (see page 18)

Deployment via BlackBerry Enterprise Server (BES)

Pushing MobilePASS for BlackBerry in BES

To push MobilePASS for BlackBerry in BES:

1. Create a shared application folder (see page 12).
2. Add to BES the shared folder where MobilePASS for BlackBerry is located (see page 12).
3. Add the MobilePASS application to be pushed to BlackBerry devices (see page 13).
4. Create and manage an application control policy for unlisted applications – setting the application to be pushed (see page 15).
5. Set parameters for MobilePASS BES deployment (see “Parameters for MobilePASS for BlackBerry Deployment” on page 21).
CHAPTER 2: Deploying MobilePASS for BlackBerry OS 7.1 and Earlier

Creating a Shared Application Folder

Create a shared folder for the MobilePASS application on the local disk of the BES or on a network volume that the BES can access.

Adding the Location of the Shared Folder Containing MobilePASS to BES

**To add the shared folder containing MobilePASS to BES:**
1. Log in to the BES Admin Console at: https://<server_name>:3443/webconsole/login/
2. Under **Servers and components**, click **BlackBerry Solution Topology > BlackBerry Domain > Component View > BlackBerry Administration Service**.
3. Scroll to the bottom of the page, click **Edit**, and then enter the application share location in the **Software management** section.
Adding the MobilePASS Application and Daemon to be Pushed to BlackBerry Devices

NOTE: The following procedure must be performed for the MobilePASS package (MobilePASS_BB.zip).

To add the MobilePASS application and daemon to be pushed to BlackBerry devices:

1. Under BlackBerry solution management, click Software > Applications > Add or update applications.

2. In the Server file path and file field, browse to the MobilePASS package .zip file.

3. Click Publish Application.

4. Click Manage Applications and confirm that the file has been added.

5. Click Create Software Configuration, enter a name for the configuration, and then click Save.

6. Click Manage Software Configurations, and then click Edit software configuration.

7. Add the software configuration, and then select the application to publish.

8. Under BlackBerry Administration Service, on the BlackBerry solution management menu, expand User.

9. Click Manage users.
   a. Search for the user accounts.
   b. Select the user accounts.
   c. In the Add to user configuration list, click Add group.
d. In the **Available groups** list, click the group to which you want to add the user accounts.

![Manage users](image)

You must search for a user to manage. You can update user information, add or change the groups and roles that a user is assigned to, and delete users.

![Available groups](image)

10. Click **Add > Save**.

11. Click **Add**.

![Manage users](image)

You must search for a user to manage. You can update user information, add or change the groups and roles that a user is assigned to, and delete users.

![Available software configurations](image)

12. Select the required configuration, click **Add** then click **Save**.

13. Click **Save all**.
CHAPTER 2: Deploying MobilePASS for BlackBerry OS 7.1 and Earlier

Creating and Managing an Application Control Policy

To create and manage an application control policy for unlisted applications – setting the application to be pushed:

1. Under BlackBerry solution management, click Software > Create an application control policies for unlisted applications.

2. Under Application control policy information, enter a Name and Description, and then click Save.

3. Click Manage application control policies for unlisted applications.

4. Click Standard Unlisted Optional. This will allow you to edit the access settings for the application.

5. Click the Access settings tab, and then click Edit application control policy (located at the bottom of the page).

6. Change Are internal network connections allowed and Are external network connections allowed options to Allowed, and then click Save All. This will allow the connection to the portal for registering MobilePASS.

7. Repeat steps 4 to 6 for Policy Not Required and the application control policy created for this deployment (SafeNet MobilePASS in this example).

8. Click Save All. This will allow the connection to the portal for registering MobilePASS.

9. Under Create a Software configuration, enter a name for the configuration, and then set Disposition for unlisted applications to Optional. Click Save.

10. Click the configuration name to edit, and then click the Applications tab.
11. Click **Add applications to software configuration** to add the MobilePASS software to the configuration.

The application has been added. It is now ready to be pushed to BlackBerry devices.

### Setting Parameters for MobilePASS BES Deployment

1. **Under BlackBerry solution management**, click **Policy > Create an IT policy**.

2. Enter a name and description for the policy, and then click **Save**.

3. **Click Manage IT Policies**.

4. **Select the IT policy created above**.
5. Click **Create an IT policy rule**.
   a. Type a name and description for one of the following IT policy rules, as listed in “Parameters for MobilePASS for BlackBerry Deployment” on page 21:
      - EnforceSafeNetMobilePassPolicy
      - DisableSafeNetMobilePassPolicy
      - SafeNetMobilePassActivationMethod
      - SafeNetMobilePassActivationURL
      - SafeNetMobilePassModifyURL
      - SafeNetMobilePassActivationFailover
      - SafeNetMobileUrlFilter
   b. In the **Type** list, select **string**.
   c. In the **Destination** list, choose whether you want the BlackBerry device, the BlackBerry® Desktop Software, or both to be able to use the IT policy rule.
   d. Click **Save**.
   e. Repeat steps 5a to 5d for each of the rules as listed in “Parameters for MobilePASS for BlackBerry Deployment” on page 21.

6. Click **Manage IT policies**.
   a. Select the required policy.
   b. Select **Edit IT Policy**.
   c. Select **User Defined**.
   d. Enter a value for each rule, if required. If the value field is left empty, the default value is applied. (See “Parameters for MobilePASS for BlackBerry Deployment” on page 21).
   e. Click **Save all**.
Installing MobilePASS on the BlackBerry Device from the SafeNet-hosted OTA Server

Note that if OTA installation is used, automatic enrollment will not work for PCE as the package needs to be customized as detailed in “Customizing MobilePASS to Enroll to a Custom SAS Installation” on page 20.

To install MobilePASS from the SafeNet-hosted OTP server:
1. From the BlackBerry device, browse to:
   
   http://update.cis-app.com/SW/mpclients/bb/OTA_latest/MobilePASS_full.jad

2. The Downloads window appears with the MobilePASS application information. Select the option Set Application Permissions and then click Download.

3. The Permissions window appears. Set the following permissions:
   
   - Connections: Allow
   - Interactions: Allow
   - User Data: Allow

4. Click Save.

5. The application will download and install on the device. When the installation is finished, click OK to close the installer or Run to start using the application.

Installing MobilePASS on the BlackBerry Device from a Web Server

To install MobilePASS from your own web server:
1. From the BlackBerry device, browse to the URL location of the MobilePASS .zip file as provided by the administrator.

2. The download window appears with the MobilePASS application information. Select Set Application Permissions and then click Download.

3. The Permissions window appears.
   a. Set the following permissions:
      
      - Connections: Allow
      - Interactions: Allow
      - User Data: Allow

   b. Click Save.

4. The application will download and install on the device. When the installation is finished, click OK to close the installer or Run to start using the application.
Hosting MobilePASS for BlackBerry on a Web Server for Over-the-Air Deployment

The BlackBerry MobilePASS application can be hosted and deployed for OTA download by users from either the SafeNet-hosted server, or from your internally-hosted server. To host and deploy the application from your internally-hosted server, the .cod and .jad files must be posted and available for users to download from the web server.

**To host BlackBerry MobilePASS on your web server:**

   
   The zipped file contains the ready-to-deploy subdirectories, including one named OTA.

2. Copy the OTA subdirectory to an accessible location.

3. Set the required MIME type on the web browser:
   
   - For .cod files, set the MIME type to `application/vnd.rim.cod`.
   - For .jad files, set the MIME type to `text/vnd.sun.j2me.app.descriptor`.

4. Place the .cod and .jad files on your internally-hosted web server for your BlackBerry users to download.

5. Provide users with the URL for your internal web server and instructions on how to browse to the .jad file and download BlackBerry MobilePASS.

Customizing MobilePASS for BlackBerry

MobilePASS for BlackBerry will work out of the box. However, you can customize it according to your company’s preferences.

To customize it, edit and append the following lines in the `MobilePASS_full.jad` file that was supplied with the package. You can use any text editor to edit the file.

- `EnforceSafeNetMobilePassPolicy`
- `DisableSafeNetMobilePassPolicy`
- `SafeNetMobilePassActivationMethod`
- `SafeNetMobilePassActivationURL`
- `SafeNetMobilePassModifyURL`
- `SafeNetMobilePassActivationFailover`

**NOTE:** The default and custom values are the same as in the BES configuration table described under “Parameters for MobilePASS for BlackBerry Deployment” on page 21.
Customizing MobilePASS to Enroll to a Custom SAS Installation

For SAS enrollment, the package, by default, points to SAS Cloud (https://cloud.safenet-inc.com). If you want to customize MobilePASS to point and enroll to a local SAS Private Cloud Enterprise (PCE) installation, edit the MobilePASSdaemon.jad file that came with the package and append the following line:

SafeNetMobileUrlFilter: <IP address or URL of local SAS>

---

**NOTE:** For valid values, see “Parameters for MobilePASS for BlackBerry Deployment” on page 21.

It's important to customize and finalize your package before you let your users download and install MobilePASS. Otherwise, if you make changes after users have downloaded and installed MobilePASS, they will need to download and install the application again.
## Parameters for MobilePASS for BlackBerry Deployment

<table>
<thead>
<tr>
<th>Rule</th>
<th>Value Type</th>
<th>Value</th>
<th>Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>EnforceSafeNetMobilePassPolicy</td>
<td>String</td>
<td>True/False</td>
<td>True</td>
<td>If False, MobilePASS ignores all other settings below and will use the default settings.</td>
</tr>
<tr>
<td>DisableSafeNetMobilePassPolicy</td>
<td>String</td>
<td>True/False</td>
<td>False</td>
<td>If False, MobilePASS always use Policy Level 1, and the user cannot define other policies. There is no automatic enrollment on Level 1. The application will always go through manual enrollment.</td>
</tr>
<tr>
<td>SafeNetMobilePassActivationURL</td>
<td>URL</td>
<td>https://&lt;IP SAM&gt;/sammobile/enroll</td>
<td>None</td>
<td>For SAM only.</td>
</tr>
<tr>
<td>SafeNetMobilePassModifyURL</td>
<td>String</td>
<td>True/false</td>
<td>True</td>
<td>For SAM only. If “ActivationURL” is not empty, &amp; value is TRUE, the SAM URL will be displayed and the user can edit it.</td>
</tr>
<tr>
<td>SafeNetMobilePassActivationFailover</td>
<td>String</td>
<td>True/false</td>
<td>True</td>
<td>If set to True and automatic enrollment fails, it will prompt for Automatic, Manual, or Cancel, and will let the user restart the enrollment with whatever the user chooses from the prompt. If set to False, the application will still failover but will prompt only for Automatic or Cancel. Manual enrollment will not be an option.</td>
</tr>
<tr>
<td>Rule</td>
<td>Value Type</td>
<td>Value</td>
<td>Default Value</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>------------</td>
<td>--------------------------------------------</td>
<td>---------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>SafeNetMobileUrlFilter</td>
<td>URL</td>
<td>&lt;SAS IP or URL without http://&gt;</td>
<td>se.safenet-inc.com</td>
<td>For SAS only. IP address or URL of the SAS server without http://</td>
</tr>
<tr>
<td></td>
<td>String</td>
<td>Example: 10.6.2.234 Or localsas.mycompany.com</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>